Till senaste kommentaren

Kan ej installera på Linux Mint

Hej
Jag har en ny dator där jag har installerat den senaste versionen av Linux Mint.
När jag försöker installera BL-ekonomi med ./blekonomi-linux.sh får jag följande meddelande:
"Configuring the installer...
Searching for JVM on the system...
Java SE Development Kit (JDK) was not found on this computer
JDK 7 is required for installing BL Ekonomi. Make sure that the JDK is properly installed and run installer again.
You can specify valid JDK location using --javahome installer argument.

To download the JDK, visit http://www.oracle.com/technetwork/java/javase/downloads/index.html"

Jag har java installerat men inte version 7 då den är gammal, och --javahome installer argument säger mig inte mycket även efter att ha googlat runt.



Kommentarer

  • Hej Johan,

    De versioner av Java som BLe funkar med är 7 och 8. Åttan är en "Long time support" så att man ska slippa uppdatera sin Java-version så ofta. Det gör också att det inte fungerar med högre versioner. Om du avinstallerar den java du har och installerar openjdk-8-jre (eller openjdk-8-jdk) så kommer det att fungera.
    Mattias Support
  • Nu gick det att installera programmet. Men inte att starta det. Det kommer upp ett fönter med "initierar" sedan försvinner det och inget händer.
    När jag startar programmet från en terminal ~/blekonomi/bin$ ./blekonomi får jag felmeddelandet
    "WARNING: An illegal reflective access operation has occurred
    WARNING: Illegal reflective access by org.netbeans.ProxyURLStreamHandlerFactory (file:/home/xxxxx/blekonomi/platform/lib/boot.jar) to field java.net.URL.handler
    WARNING: Please consider reporting this to the maintainers of org.netbeans.ProxyURLStreamHandlerFactory
    WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
    WARNING: All illegal access operations will be denied in a future release
    UI class not found, using default UI..."

    Johan
  • Hej igen!

    Det verkar som om du fortfarande har fler, och nyare, java-versioner installerade. Du kan antingen avinstallera den/dom eller peka ut för BL Ekonomi var den hittar java8.
    Det gör du i:

    ~/blekonomi/etc/blekonomi.conf

    Redigera raden:

    #jdkhome="/path/to/jdk"

    så att den blir (i mitt fall, kontrollera sökvägen så den stämmer hos dig):

    jdkhome="/usr/lib/jvm/java-8-openjdk-amd64"

    Om du inte behöver senaste java-versionen är det ju enklast att ta bort den.
    Mattias Support

Kommentera eller skriv ett nytt inlägg

Ditt namn och inlägg kan ses av alla. Din e-post visas aldrig publikt.

Mitt inlägg förmodereras innan eventuell publicering. Jag har tagit del av policyn för personuppgifter och innehåll.